Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Scaladoc Tool
    • Labels:
    • Environment:

      scaladoc tags

      Description

      === What steps will reproduce the problem (please be specific and use wikiformatting)? ===

      abstract class test
      /**
       * TestA class
       * @example 2.0
       * @todo do something better than finding scaladoc bugs
       * @note blah blah */
      class TestA extends test
      

      === What is the expected behavior? ===

      I expect to generate notes, examples, and todos.

      === What do you see instead? ===

      No notes, examples, or todos see attached.

      === Additional information ===
      http://permalink.gmane.org/gmane.comp.lang.scala.user/37949

      === What versions of the following are you using? ===

      • Scala: 2.8.1.final
      • Java: 1.6.0_24
      • Operating system: MacOS

        Activity

        Gilles Dubochet added a comment -

        I am actually not sure "todos" should be in the generated documentation by default. I see those as notes left for developers of the code (who would be looking at the code itself), not for users of the library who use the documentation.

        Commit Message Bot added a comment -

        (extempore in r25450) Adds support in Scaladoc for @todo tag. Contributed by Steven Tomcavage. Related to SI-4421. No review.

        Heather Miller added a comment -

        I merged Steven's contribution, so now the status looks like everything listed works.

        Works:

        @example
        @note
        @return
        @see
        @since
        @version
        @throws
        @todo

        I'll leave this ticket open pending discussion of the role/need for the @todo tag.

        Vlad Ureche added a comment -

        All of them are working on trunk. Closing.

        Robin Green added a comment -

        Todos can be useful because they can tell the user what is expected to be coming in later versions, and hence also what is not yet implemented. Todos that you don't want to be visible in the scaladoc can be put in ordinary non-scaladoc comments.


          People

          • Assignee:
            Unassigned
            Reporter:
            s wade
          • Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development