Scala Programming Language
  1. Scala Programming Language
  2. SI-4705

Interpreter blocks on ctrl-d (OS X, at least)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Repl / Interpreter
    • Labels:
      None
    • Environment:

      latest nightly build 2.10.0.r25100-b20110617020235

      Description

      typing "ctrl-d" blocks the interpreter, it doesn't echo anymore. with "ctrl-c" you one can kill it and get back to the terminal.

        Activity

        Paul Phillips added a comment -

        I turned a few funny looking knobs and sliders based on mark's comment. Any problem havers want to try out a new build and see if it made any difference? r25390 is the relevant commit.

        Johannes Rudolph added a comment -

        Ubuntu 11.04 here, same problem with 2.9.1.RC1/2.

        I tried with scala-compiler-2.10.0-20110815.021856-122.jar and Ctrl+D works now in sbt console again.

        Paul Phillips added a comment -

        If you guys can try RC3 ASAP (whenever it's out) and make sure it's fixed that'd be great.

        Also, Johannes, can you verify that SI-4844 is fixed for you.

        Johannes Rudolph added a comment -

        In 2.9.1.RC3, Ctrl-C/D work with sbt 0.7.7 and standalone interpreter as intended in Ubuntu 11.04.

        Mark Harrah added a comment -

        Closing, as the fix has been confirmed to work and there have not been any complaints since 2.9.1.final has been released that I am aware of.


          People

          • Assignee:
            Paul Phillips
            Reporter:
            Lukas Rytz
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development