Scala Programming Language
  1. Scala Programming Language
  2. SI-4999

Compiler fails to process new Set4(or Set3, Set2) from collection.immutable.Set.Set4

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: Scala 2.9.0-1, Scala 2.9.1
    • Fix Version/s: None
    • Component/s: Collections, Misc Compiler
    • Labels:
    • Environment:

      Scala version 2.9.1.final (Java HotSpot(TM) Client VM, Java 1.6.0_26).

      Description

      >>import collection.immutable.Set.Set4
      >>new Set4[Int](1,2,3,4)
      java.lang.Error: Unexpected New
      at scala.tools.nsc.symtab.SymbolTable.abort(SymbolTable.scala:34)
      at scala.tools.nsc.backend.icode.GenICode$ICodePhase.scala$tools$nsc$bac
      ..........................
      That entry seems to have slain the compiler. Shall I replayscala:660)
      your session? I can re-run each line except the last one.reach(ListBuffer.scala:
      [y/n]?

      Here you can find full description.
      http://stackoverflow.com/questions/7431346/strange-behavior-of-set4-in-scala-2-9-1

        Activity

        Paul Phillips added a comment -

        Another duplicate of SI-4987. Popular bug.


          People

          • Assignee:
            Paul Phillips
            Reporter:
            Rinat Tainov
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved:

              Development