Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: Scala 2.9.1, Scala 2.10.0
    • Fix Version/s: None
    • Component/s: Repl / Interpreter
    • Labels:
      None
    • Environment:

      Scala 2.9.1 and Scala 2.10 (820491, which is about a month ago)
      MacOS X 10.7.2
      Java 1.7.0 and Apple's Java 1.6.0_29

      Description

      Using the -i option to preload a file in the REPL appears to hang its startup. The following terminal session says it all:

      daniel@edi ~ λ cat > /tmp/test.scala
      println("hello!")
      val test = 42
      <ctrl-d>
      daniel@edi ~ λ scala -i /tmp/test.scala
      Loading /tmp/test.scala...
      <crickets sing...>
      <ctrl-c>
      daniel@edi ~ λ

      It doesn't seem to matter what the contents of the file happen to be. Even an empty file is sufficient to reproduce this behavior. This happens for me both with 2.9.1.final, and a (slightly outdated) build of 2.10 from master. Exact environment details given in the ticket attributes.

        Issue Links

          Activity

          Daniel Spiewak added a comment -

          Duplicate of SI-4945. Wasn't able to find the issue via Google, but Kenji Yoshida found it for me on Twitter.


            People

            • Assignee:
              Paul Phillips
              Reporter:
              Daniel Spiewak
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development