Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Concurrent data structures, concurrent tries, execution contexts [Parallel Collections] #5486

Closed
scabug opened this issue Feb 15, 2012 · 3 comments
Assignees
Milestone

Comments

@scabug
Copy link

scabug commented Feb 15, 2012

Add support for implementing a parallel collection using a concurrent collection. In particular, one should be able to implement a combiner using a concurrent (thread-safe) collection.

Add Ctries to the standard library. Implement parallel ctries using the above mechanism.

Enable execution contexts on parallel collections, to enable customizing a thread pool, number of threads, etc.

@scabug
Copy link
Author

scabug commented Feb 15, 2012

Imported From: https://issues.scala-lang.org/browse/SI-5486?orig=1
Reporter: @adriaanm

@scabug
Copy link
Author

scabug commented Feb 16, 2012

@soc said (edited on Feb 16, 2012 1:27:39 PM UTC):
Is it possible to change the class name of Ctrie to something more in line with the style guide out there?
Having "ConcurrentHashMap" in Java I think "ConcurrentTrie" is a reasonable choice. Imho it is very dangerous to not follow the standard naming without a very good reason, because it serves as precedent and excuse for users to ignore naming conventions in their own code.

Scala Style guide:

bq. Classes should be named in the camelCase style with the very first letter of the name capitalized [...] This mimics the Java naming convention for classes.

http://docs.scala-lang.org/style/naming-conventions.html#classestraits

Java naming conventions:

bq. Class names should be nouns, in mixed case with the first letter of each internal word capitalized. Try to keep your class names simple and descriptive. Use whole words-avoid acronyms and abbreviations (unless the abbreviation is much more widely used than the long form, such as URL or HTML).

http://www.oracle.com/technetwork/java/javase/documentation/codeconventions-135099.html#367

@scabug
Copy link
Author

scabug commented Feb 16, 2012

@axel22 said:
As I've said before, it might be worthwhile to raise a topic on the scala-internals.

IMO Ctrie is easier to write than CTrie.

@scabug scabug closed this as completed Mar 20, 2012
@scabug scabug added this to the 2.10.0 milestone Apr 7, 2017
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

2 participants