Scala Programming Language
  1. Scala Programming Language
  2. SI-5782

nested macro usage fails in SLICK: failed to typecheck against macro def return type: not found: value free$q8

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: Scala 2.10.0-M3
    • Fix Version/s: Scala 2.10.0
    • Component/s: Macros
    • Labels:
      None

      Description

      The responsible lines are:

      val q = Queryable[CoffeesTable]
      q.map(e1 => q.map(e2=>e1))
      

      It did work with earlier versions of trunk.

      The easiest way to reproduce the problem is:

        Activity

        Eugene Burmako added a comment -

        Bug acknowledged, let's discuss this in an upcoming meeting


          People

          • Assignee:
            Eugene Burmako
            Reporter:
            Christopher Vogt
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development