Scala Programming Language
  1. Scala Programming Language
  2. SI-5895

Reflection: FieldMirror is a leaky abstraction

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: Scala 2.10.0
    • Fix Version/s: Scala 2.10.0-M5
    • Component/s: Reflection
    • Labels:
      None

      Description

      The problem is demonstrated in SI-5889, in which reflectField is passed a method symbol and bad things happen.

      Well, you can say, implement a sanity check and don't pass non-field symbols to reflectField. But that gets ugly very quickly, because to get a handle on a field symbol one needs to append nme.LOCAL_SUFFIX_STRING to the field's name. To put it in a nutshell, the "field symbol" is not a good one.

      Another idea of fixing the problem would be to do away with FieldMirrors and require all field accesses to go through accessor methods. Unfortunately, this won't work either, since not all fields generate accessors (e.g. private[this] ones).

        Activity


          People

          • Assignee:
            Eugene Burmako
            Reporter:
            Eugene Burmako
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development