Scala Programming Language
  1. Scala Programming Language
  2. SI-6456

scala.math.BigDecimal should not accept a null value

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Scala 2.11.0-M8
    • Component/s: None
    • Labels:
      None

      Description

      The scala.math.BigDecimal wrapper can currently wrap null values. This can be tricky as clients will need to handle null checking on the wrapper as well as the wrapped object. The problem is compounded when implicit conversion from the java equivalent is applied.
      scala.math.BigdDecima.javaBigDecimal2bigDecimal should handle the null value and avoid wrapping it.

        Activity


          People

          • Assignee:
            Rex Kerr
            Reporter:
            Ralph C
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development