Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Misc Compiler
    • Labels:
    • Environment:

      MSIL

      Description

      Right now it is a pile of doo doo with lots of static state, meaning it can't be used in the IDE or resident compiler. It really needs to be rewritten with the static state externalized so we can have multiple copies of msil.jar for multiple instances of the compiler.

      This is really important, I want to hack in IDE support for Scala.NET as soon as possible. I'm almost there, this is the biggest blocking issue.

        Activity

        Geoffrey Alan Washburn added a comment -

        This is kind of a duplicate of SI-307, but maybe it would be better to close SI-307.

        David R. MacIver added a comment -

        Isn't this fixed as of r15095?

        Martin Odersky added a comment -

        Milestone next_bugfix deleted


          People

          • Assignee:
            Unassigned
            Reporter:
            mcdirmid
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development