Scala Programming Language
  1. Scala Programming Language
  2. SI-7091

java.lang.RuntimeException: no acc def buf for package interpolation

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: Scala 2.10.0
    • Fix Version/s: Scala 2.10.2-RC1
    • Component/s: None

      Description

      I get the error consistently when compiling my project (large project, Scala 2.10 and scala-maven-plugin 3.1.3).

      I've included what I can from the log, and can possibly provide the rest of it privately if it'll help any. I can't figure anything out from the log other than the probable source file, which is not overly complicated and compiles fine under 2.9.2; as a result I can't provide a reduced repro, nor can I continue my efforts to migrate our codebase to 2.10.

      unhandled exception while transforming file.scala
      [ERROR]      while compiling: /Users/tomer/<elided>/file.scala
              during phase: superaccessors
           library version: version 2.10.0
          compiler version: version 2.10.0
        reconstructed args: <elided>
      
        last tree to typer: TypeTree(class List)
                    symbol: class List in package immutable (flags: sealed abstract)
         symbol definition: sealed abstract class List[+A] extends AbstractSeq[A] with LinearSeq[A] with Product with GenericTraversableTemplate[A,List] with LinearSeqOptimized[A,List[A]]
                       tpe: List[<elided>]
             symbol owners: class List -> package immutable
            context owners: value <elided>
      
      == Expanded type of tree ==
      
      TypeRef(
        TypeSymbol(
          sealed abstract class List[+A] extends AbstractSeq[A] with LinearSeq[A] with Product with GenericTraversableTemplate[A,List] with LinearSeqOptimized[A,List[A]]
          
        )
        args = List(
          TypeRef(TypeSymbol(abstract class Elided extends Object))
        )
      )
      
      
      uncaught exception during compilation: java.lang.RuntimeException
      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      [INFO] 
      ...
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 43.488s
      [INFO] Finished at: Wed Feb 06 15:23:04 IST 2013
      [INFO] Final Memory: 40M/327M
      [INFO] ------------------------------------------------------------------------[ERROR] Failed to execute goal net.alchim31.maven:scala-maven-plugin:3.1.3:compile (scala-compile-first) on project harvester: Execution scala-compile-first of goal net.alchim31.maven:scala-maven-plugin:3.1.3:compile failed: no acc def buf for package interpolation -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal net.alchim31.maven:scala-maven-plugin:3.1.3:compile (scala-compile-first) on project harvester: Execution scala-compile-first of goal net.alchim31.maven:scala-maven-plugin:3.1.3:compile failed: no acc def buf for package interpolation
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:225)
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
              at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
              at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
              at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
              at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
              at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
              at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
              at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
              at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
              at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
              at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
              at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
              at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
      Caused by: org.apache.maven.plugin.PluginExecutionException: Execution scala-compile-first of goal net.alchim31.maven:scala-maven-plugin:3.1.3:compile failed: no acc def buf for package interpolation
              at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:110)
              at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
              ... 19 more
      Caused by: java.lang.RuntimeException: no acc def buf for package interpolation
              at scala.sys.package$.error(package.scala:27)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer$$anonfun$1.apply(SuperAccessors.scala:54)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer$$anonfun$1.apply(SuperAccessors.scala:54)
              at scala.collection.MapLike$class.getOrElse(MapLike.scala:128)
              at scala.collection.AbstractMap.getOrElse(Map.scala:58)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.scala$tools$nsc$typechecker$SuperAccessors$SuperAccTransformer$$storeAccessorDefinition(SuperAccessors.scala:54)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.ensureAccessor(SuperAccessors.scala:62)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transformSelect$1(SuperAccessors.scala:297)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:316)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:43)
              at scala.reflect.internal.Trees$class.itransform(Trees.scala:1188)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.api.Trees$Transformer.transform(Trees.scala:2833)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.transform(TypingTransformers.scala:48)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.mayNeedProtectedAccessor$1(SuperAccessors.scala:164)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transformSelect$1(SuperAccessors.scala:313)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:316)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer$$anonfun$transformArgs$1.apply(SuperAccessors.scala:81)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer$$anonfun$transformArgs$1.apply(SuperAccessors.scala:78)
              at scala.reflect.internal.TreeInfo$$anonfun$mapMethodParamsAndArgs$1.apply(TreeInfo.scala:115)
              at scala.reflect.internal.TreeInfo$$anonfun$mapMethodParamsAndArgs$1.apply(TreeInfo.scala:115)
              at scala.reflect.internal.util.Collections$class.foreach2(Collections.scala:150)
              at scala.reflect.internal.SymbolTable.foreach2(SymbolTable.scala:12)
              at scala.reflect.internal.TreeInfo.foreachMethodParamAndArg(TreeInfo.scala:130)
              at scala.reflect.internal.TreeInfo.mapMethodParamsAndArgs(TreeInfo.scala:115)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transformArgs(SuperAccessors.scala:78)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:340)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer$$anonfun$transformArgs$1.apply(SuperAccessors.scala:81)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer$$anonfun$transformArgs$1.apply(SuperAccessors.scala:78)
              at scala.reflect.internal.TreeInfo$$anonfun$mapMethodParamsAndArgs$1.apply(TreeInfo.scala:115)
              at scala.reflect.internal.TreeInfo$$anonfun$mapMethodParamsAndArgs$1.apply(TreeInfo.scala:115)
              at scala.reflect.internal.util.Collections$class.foreach2(Collections.scala:150)
              at scala.reflect.internal.SymbolTable.foreach2(SymbolTable.scala:12)
              at scala.reflect.internal.TreeInfo.foreachMethodParamAndArg(TreeInfo.scala:130)
              at scala.reflect.internal.TreeInfo.mapMethodParamsAndArgs(TreeInfo.scala:115)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transformArgs(SuperAccessors.scala:78)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:340)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:43)
              at scala.reflect.api.Trees$Transformer$$anonfun$transformStats$1.apply(Trees.scala:2863)
              at scala.reflect.api.Trees$Transformer$$anonfun$transformStats$1.apply(Trees.scala:2861)
              at scala.collection.immutable.List.loop$1(List.scala:164)
              at scala.collection.immutable.List.mapConserve(List.scala:180)
              at scala.reflect.api.Trees$Transformer.transformStats(Trees.scala:2861)
              at scala.reflect.internal.Trees$class.itransform(Trees.scala:1209)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.api.Trees$Transformer.transform(Trees.scala:2833)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.transform(TypingTransformers.scala:48)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:348)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:343)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer$$anonfun$transformArgs$1.apply(SuperAccessors.scala:81)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer$$anonfun$transformArgs$1.apply(SuperAccessors.scala:78)
              at scala.reflect.internal.TreeInfo$$anonfun$mapMethodParamsAndArgs$1.apply(TreeInfo.scala:115)
              at scala.reflect.internal.TreeInfo$$anonfun$mapMethodParamsAndArgs$1.apply(TreeInfo.scala:115)
              at scala.reflect.internal.util.Collections$class.foreach2(Collections.scala:150)
              at scala.reflect.internal.SymbolTable.foreach2(SymbolTable.scala:12)
              at scala.reflect.internal.TreeInfo.foreachMethodParamAndArg(TreeInfo.scala:130)
              at scala.reflect.internal.TreeInfo.mapMethodParamsAndArgs(TreeInfo.scala:115)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transformArgs(SuperAccessors.scala:78)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:340)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:43)
              at scala.reflect.api.Trees$Transformer$$anonfun$transformStats$1.apply(Trees.scala:2863)
              at scala.reflect.api.Trees$Transformer$$anonfun$transformStats$1.apply(Trees.scala:2861)
              at scala.collection.immutable.List.loop$1(List.scala:164)
              at scala.collection.immutable.List.mapConserve(List.scala:180)
              at scala.reflect.api.Trees$Transformer.transformStats(Trees.scala:2861)
              at scala.reflect.internal.Trees$class.itransform(Trees.scala:1209)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.api.Trees$Transformer.transform(Trees.scala:2833)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.transform(TypingTransformers.scala:48)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:348)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:43)
              at scala.reflect.internal.Trees$$anonfun$itransform$2.apply(Trees.scala:1206)
              at scala.reflect.internal.Trees$$anonfun$itransform$2.apply(Trees.scala:1204)
              at scala.reflect.api.Trees$Transformer.atOwner(Trees.scala:2872)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:34)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.atOwner(SuperAccessors.scala:372)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:28)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:19)
              at scala.reflect.internal.Trees$class.itransform(Trees.scala:1203)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.api.Trees$Transformer.transform(Trees.scala:2833)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.transform(TypingTransformers.scala:48)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:348)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:43)
              at scala.reflect.api.Trees$Transformer$$anonfun$transformTrees$1.apply(Trees.scala:2836)
              at scala.reflect.api.Trees$Transformer$$anonfun$transformTrees$1.apply(Trees.scala:2836)
              at scala.collection.immutable.List.loop$1(List.scala:164)
              at scala.collection.immutable.List.mapConserve(List.scala:180)
              at scala.reflect.api.Trees$Transformer.transformTrees(Trees.scala:2836)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer$$anonfun$6.apply(SuperAccessors.scala:216)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer$$anonfun$6.apply(SuperAccessors.scala:216)
              at scala.reflect.api.Trees$Transformer.atOwner(Trees.scala:2872)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:34)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.atOwner(SuperAccessors.scala:372)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transformTemplate$1(SuperAccessors.scala:216)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:221)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:43)
              at scala.reflect.api.Trees$Transformer.transformTemplate(Trees.scala:2840)
              at scala.reflect.internal.Trees$$anonfun$itransform$4.apply(Trees.scala:1251)
              at scala.reflect.internal.Trees$$anonfun$itransform$4.apply(Trees.scala:1250)
              at scala.reflect.api.Trees$Transformer.atOwner(Trees.scala:2872)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:34)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.atOwner(SuperAccessors.scala:372)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:28)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:19)
              at scala.reflect.internal.Trees$class.itransform(Trees.scala:1249)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.api.Trees$Transformer.transform(Trees.scala:2833)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.transform(TypingTransformers.scala:48)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transformClassDef$1(SuperAccessors.scala:198)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:200)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:43)
              at scala.reflect.api.Trees$Transformer$$anonfun$transformStats$1.apply(Trees.scala:2863)
              at scala.reflect.api.Trees$Transformer$$anonfun$transformStats$1.apply(Trees.scala:2861)
              at scala.collection.immutable.List.loop$1(List.scala:164)
              at scala.collection.immutable.List.mapConserve(List.scala:180)
              at scala.reflect.api.Trees$Transformer.transformStats(Trees.scala:2861)
              at scala.reflect.internal.Trees$$anonfun$itransform$7.apply(Trees.scala:1269)
              at scala.reflect.internal.Trees$$anonfun$itransform$7.apply(Trees.scala:1269)
              at scala.reflect.api.Trees$Transformer.atOwner(Trees.scala:2872)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:34)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.atOwner(SuperAccessors.scala:372)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:28)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:19)
              at scala.reflect.internal.Trees$class.itransform(Trees.scala:1268)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.internal.SymbolTable.itransform(SymbolTable.scala:12)
              at scala.reflect.api.Trees$Transformer.transform(Trees.scala:2833)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.scala$tools$nsc$transform$TypingTransformers$TypingTransformer$$super$transform(TypingTransformers.scala:44)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer$$anonfun$transform$2.apply(TypingTransformers.scala:46)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer$$anonfun$transform$2.apply(TypingTransformers.scala:46)
              at scala.reflect.api.Trees$Transformer.atOwner(Trees.scala:2872)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.atOwner(TypingTransformers.scala:34)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.atOwner(SuperAccessors.scala:372)
              at scala.tools.nsc.transform.TypingTransformers$TypingTransformer.transform(TypingTransformers.scala:46)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:348)
              at scala.tools.nsc.typechecker.SuperAccessors$SuperAccTransformer.transform(SuperAccessors.scala:43)
              at scala.tools.nsc.ast.Trees$Transformer.transformUnit(Trees.scala:227)
              at scala.tools.nsc.transform.Transform$Phase.apply(Transform.scala:30)
              at scala.tools.nsc.Global$GlobalPhase.applyPhase(Global.scala:461)
              at scala.tools.nsc.Global$GlobalPhase$$anonfun$run$1.apply(Global.scala:428)
              at scala.tools.nsc.Global$GlobalPhase$$anonfun$run$1.apply(Global.scala:428)
              at scala.collection.Iterator$class.foreach(Iterator.scala:727)
              at scala.collection.AbstractIterator.foreach(Iterator.scala:1156)
              at scala.tools.nsc.Global$GlobalPhase.run(Global.scala:428)
              at scala.tools.nsc.Global$Run.compileUnitsInternal(Global.scala:1574)
              at scala.tools.nsc.Global$Run.compileUnits(Global.scala:1548)
              at scala.tools.nsc.Global$Run.compileSources(Global.scala:1544)
              at scala.tools.nsc.Global$Run.compile(Global.scala:1654)
              at xsbt.CachedCompiler0.run(CompilerInterface.scala:90)
              at xsbt.CachedCompiler0.run(CompilerInterface.scala:72)
              at xsbt.CompilerInterface.run(CompilerInterface.scala:26)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
              at java.lang.reflect.Method.invoke(Method.java:597)
              at sbt.compiler.AnalyzingCompiler.call(AnalyzingCompiler.scala:73)
              at sbt.compiler.AnalyzingCompiler.compile(AnalyzingCompiler.scala:35)
              at sbt.compiler.AnalyzingCompiler.compile(AnalyzingCompiler.scala:29)
              at sbt.compiler.AggressiveCompile$$anonfun$4$$anonfun$compileScala$1$1.apply$mcV$sp(AggressiveCompile.scala:71)
              at sbt.compiler.AggressiveCompile$$anonfun$4$$anonfun$compileScala$1$1.apply(AggressiveCompile.scala:71)
              at sbt.compiler.AggressiveCompile$$anonfun$4$$anonfun$compileScala$1$1.apply(AggressiveCompile.scala:71)
              at sbt.compiler.AggressiveCompile.sbt$compiler$AggressiveCompile$$timed(AggressiveCompile.scala:101)
              at sbt.compiler.AggressiveCompile$$anonfun$4.compileScala$1(AggressiveCompile.scala:70)
              at sbt.compiler.AggressiveCompile$$anonfun$4.apply(AggressiveCompile.scala:88)
              at sbt.compiler.AggressiveCompile$$anonfun$4.apply(AggressiveCompile.scala:60)
              at sbt.inc.IncrementalCompile$$anonfun$doCompile$1.apply(Compile.scala:24)
              at sbt.inc.IncrementalCompile$$anonfun$doCompile$1.apply(Compile.scala:22)
              at sbt.inc.Incremental$.cycle(Incremental.scala:40)
              at sbt.inc.Incremental$.compile(Incremental.scala:25)
              at sbt.inc.IncrementalCompile$.apply(Compile.scala:20)
              at sbt.compiler.AggressiveCompile.compile2(AggressiveCompile.scala:96)
              at sbt.compiler.AggressiveCompile.compile1(AggressiveCompile.scala:44)
              at com.typesafe.zinc.Compiler.compile(Compiler.scala:158)
              at com.typesafe.zinc.Compiler.compile(Compiler.scala:142)
              at sbt_inc.SbtIncrementalCompiler.compile(SbtIncrementalCompiler.java:73)
              at scala_maven.ScalaCompilerSupport.incrementalCompile(ScalaCompilerSupport.java:289)
              at scala_maven.ScalaCompilerSupport.compile(ScalaCompilerSupport.java:118)
              at scala_maven.ScalaCompilerSupport.doExecute(ScalaCompilerSupport.java:99)
              at scala_maven.ScalaMojoSupport.execute(ScalaMojoSupport.java:461)
              at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
              ... 20 more
      

      I'm at a complete loss as to what could be wrong here. Any help would be appreciated...

        Activity

        Jason Zaugg added a comment -

        We can't help you without more details. Can you please send me a zip of the project? My mail is jason.zaugg@typesafe.com.

        Jason Zaugg added a comment -

        @Tomer: we are about to lock down the release of 2.10.1. I would love to characterize the problem to include a fix, but I would need to be able to reproduce it by the end of the week.

        Tomer Gabel added a comment -

        @Jason: Thank you. I'm trying to cut through the red tape at my company, and will see what I can do.

        Tomer Gabel added a comment -

        The good news: I've been able to work around and reduce the problem significantly. The bad news: I haven't been able to generate a good repro. This is actually somewhat similar to SI-1393 and SI-1094. I'll mail you what I can and we'll take it from there.

        Jason Zaugg added a comment -

        Added a diagnostic: https://github.com/retronym/scala/compare/scala:2.10.x...retronym:ticket/7091, we'll see what that turns on in Tomer's code base.

        Jason Zaugg added a comment -

        Regressed in https://github.com/scala/scala/commit/f708b87, but I suspect that this just unmasked a problem introduced earlier in NamesDefaults https://github.com/scala/scala/commit/185b1c8.

        Test case:

        package p1
        
        protected[p] class C(var x: Int = 0)
        
        protected[p] trait T {
          new C()
        }
        
        Jason Zaugg added a comment - - edited

          People

          • Assignee:
            Jason Zaugg
            Reporter:
            Tomer Gabel
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development