Details

      Description

      In order to match Scala jars with their sources in Eclipse, a few additional lines need to be added in the MANIFEST.MF file inside source jars:

      Bundle-SymbolicName: org.scala-lang.scala-compiler.source
      Bundle-Version: ${osgi.version}
      Eclipse-SourceBundle: org.scala-lang.scala-compiler;version="${osgi.version}";roots:="."
      

        Activity

        Show
        Iulian Dragos added a comment - PR: https://github.com/scala/scala/pull/2970
        Hide
        Jason Zaugg added a comment -

        When we backport, just please add fix version for 2.10.x

        Show
        Jason Zaugg added a comment - When we backport, just please add fix version for 2.10.x

          People

          • Assignee:
            Josh Suereth
            Reporter:
            Iulian Dragos
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development